Error: System.Runtime.InteropServices.COMException (0×80040417)

Symptom

Error: System.Runtime.InteropServices.COMException (0x80040417).

Cause

This error message typically displays when a QuickBooks company file is no longer properly integrated with SmartVault.

Resolution

To resolve this issue, re-integrate the QuickBooks company file with SmartVault.

To re-integrate a QuickBooks company file with SmartVault:

  1. In QuickBooks, on the Edit menu, click Preferences.
  2. In the left pane, click Integrated Applications.
  3. In the right pane, on the Company Preferences tab, under Application Name, select SmartVault
  4. Click Remove, and then click Yes.
  5. Note: If you have upgraded your SmartVault Desktop software from SmartVault version 3.0 or lower to SmartVault version 3.1 or higher, you may have two instances of SmartVault listed under Application Name. Remove both instances of SmartVault from the list.

  6. Close the Preferences dialog box, and click Yes to save your changes if prompted.
  7. Close QuickBooks.
  8. Right click on the SmartVault icon in the system tray and select Exit.
  9. Restart QuickBooks.
  10. Open the QuickBooks company file you want to re-integrate with SmartVault as an Admin in single-user mode by completing one of the following steps:
    1. If you are the only user for the QuickBooks company file, by default you are already in single-user mode and you are the Admin. Simply type the password for your QuickBooks company file, and then click OK.

      Your QuickBooks login screen should be similar to the following image.

    2. If your QuickBooks company file is used by more than one user, ensure that no other users are currently using the QuickBooks company file, and then in the User Name field, type Admin, and in the Password field, type the password for the Admin user, and then click OK.

      Note: If you do not know the password for the Admin user, contact the person who created the QuickBooks company file or refer to the QuickBooks help for more information about working with QuickBooks passwords.

      Your QuickBooks login screen should be similar to the following image.

  11. When you open the QuickBooks company file, a QuickBooks – Application Certificate dialog box displays, telling you that SmartVault is requesting access to the QuickBooks company file and asking you to accept the SmartVault security certificate. You must accept the SmartVault security certificate in order to re-integrate SmartVault with the QuickBooks company file.

    When the QuickBooks – Application Certificate dialog box displays, complete the following steps:

    1. Select Yes, always; allow access even if QuickBooks is not running.
    2. If your QuickBooks company file is used by more than one user, in the Login as field, select Admin from the drop-down list.
    3. Click Continue.
    4. The dialog box you see should be similar to the following image.

  12. In the Access Confirmation dialog box, click Done.
  13. The dialog box you see should be similar to the following image.

    The SmartVault Toolbar should now display on the right side of your QuickBooks window, and your QuickBooks window should be similar to the following image:

  14. If the SmartVault Toolbar still does not display on the right side of your QuickBooks window, it is typically because you are working in an environment where your SmartVault Desktop software was upgraded from SmartVault version 3.0 or lower to SmartVault version 3.1 or higher.

    Due to a known issue with how QuickBooks works with VeriSign security certificates, QuickBooks has a problem with correctly recognizing updated security certificates, including the updated security certficate included in version 3.1 or higher of the SmartVault Desktop software. This issue prevents the SmartVault Toolbar from displaying correctly in QuickBooks until you close the QuickBooks company file, and then open and close the QuickBooks company file two or three times, logging in as Admin each time you open the company file.

  15. Open and close the QuickBooks company file two or three times to force QuickBooks to recognize updated security certificates.

    When the QuickBooks Application Certificate dialog box displays again, verify that correct, updated SmartVault 2009 security certificate now displays. The dialog box you see should be similar to the following image.

  16. Accept the security certificate by completing the following steps:
    1. Select Yes, always; allow access even if QuickBooks is not running.
    2. If your QuickBooks company file is used by more than one user, in the Login as field, select Admin from the drop-down list.
    3. Click Continue.
  17. When the Access Confirmation dialog box displays again, click Done.

    The dialog box you see should be similar to the following image:

  18. The SmartVault Toolbar should now display on the right side of your QuickBooks window, and your QuickBooks window should be similar to the following image:

Knowledge Base ID

KB134

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