Error: System.Runtime.InteropServices.COMException (0×80040408)

Symptoms

  • Error: System.Runtime.InteropServices.COMException (0x80040408)
  • Could not start QuickBooks.

Cause

This error is typically caused by some or all of the following conditions:

  • Vista User Account Control (UAC) is disabled.
  • The logged in user to the system belongs to the “Admin” group.
  • The QuickBooks company file you are trying to open is in a Protected folder in a network environment.

Resolution

To resolve this issue:

  1. If your computer is running Windows Vista, complete the following steps:
    1. Ensure that Vista User Account Control (UAC) is enabled. For more information about enabling UAC, see http://www.howtonetworking.com/vista/disableuac.htm.
    2. Ensure that the user logged in to the system is not an administrator or member of the “Admin” group.
    3. Ensure the QuickBooks company file is in a PUBLIC folder in a network environment or a PRIVATE (Home) folder in a single-user environment.
  2. If your computer is running Windows XP, complete the following steps:
    1. Close QuickBooks and exit out of SmartVault.
    2. Browse to \ProgramFiles\Intuit\QuickBooks Version\Components\RegisteredUI.
    3. Rename the file UI_sdk_smartvault.SYS to
      OLD_UI_sdk_smartvault.SYS.
    4. Restart QuickBooks and sign in to SmartVault.

    Knowledge Base ID

    KB136

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