Symptoms
Error: COMException (0x80040402) This application is not allowed to login automatically. Check the qbsdklog.txt file for possible additional informationdisplays when you try and open a QuickBooks company file that has been added to SmartVault.Error: 0x8004041D This application is not allowed to log into this QuickBooks company data filedisplays when you try and open a QuickBooks company file that has been added to SmartVault.
When you check the qbsdklog.txt file, the QuickBooks SDK log displays the following error:
This application is not allowed to log in automatically to this QuickBooks company file and automatic login is required; the QuickBooks Administrator can grant permission through the Integrated Applications preferences.
Cause
One or both of these error messages display when you try and open a QuickBooks company file that has been added to SmartVault but settings in the Integrated Applications dialog box in QuickBooks prevent SmartVault from communicating with the QuickBooks company file.
Resolution
To resolve this issue, configure QuickBooks to accept automatic logins from the SmartVault Desktop software.
To configure QuickBooks to accept automatic logins from the SmartVault Desktop software:
- Right-click on the SmartVault icon in the system tray, and then click Exit.
- Open QuickBooks and log in as Admin in single user mode.
- In QuickBooks, on the Edit menu, click Preferences.
- In the left pane, click Integrated Applications.
- On the Company Preferences tab, select SmartVault, and then click Properties.
- Select the Yes, always; allow even if QuickBooks is not running check box, and choose Admin as the Login user.
- Click OK, and then click OK again.
- Close the QuickBooks company file.
- Click on Start > Programs > SmartVault > SmartVault.
- Open the QuickBooks company file as a non-Admin user.
Note: To ensure you are in single-user mode in QuickBooks, click File and verify that the Switch to Multi-user Mode option displays in the File menu. If the Switch to Single User Mode option displays in the File menu, you are in multi-user mode. Click Switch to Single-user mode to switch to single-user mode.
Note: If your SmartVault Desktop software has been upgraded from a version prior to SmartVault 3.0, you may need to modify both instances of SmartVault in the Integrated Applications dialog box.
Error messages should no longer display and the SmartVault Toolbar should display correctly.
Knowledge Base ID
KB180


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