Symptom
Error: Object reference not set to an instance of an object at SVault.Client.QuickBooks.ContextDataLayer.ContextDataAccess.ReadAssociation SVault.Client.QuickBooks.QuickBooksDatabase.ReadAssociation(String&companyName) at SVault.Client.QuickBooks.QuickBooksDetails.ReadAssociation (String&
name) at SVault.Client.QuickBooks.QBHostContext.GetDatabaseOnOpen(IApplicationContextDetails details, Boolean newDB)
Cause
This error message typically displays when you try to add a QuickBooks company file that has been converted from the QuickBooks online format to the Quickbooks desktop format to SmartVault.
Resolution
To resolve this issue, verify that you have the latest SmartVault Desktop software installed on your computer. Your SmartVault Desktop software version must be higher than v3.1.102.18.
To verify that you have the latest SmartVault Desktop software installed:
- Right-click the SmartVault icon in your system tray.
- Click About.
- If your SmartVault Desktop software version is 3.1.102.18 or lower, complete the following steps:
- If QuickBooks is open, close QuickBooks.
- Right-click on the SmartVault icon in your system tray or right-click on the SmartVault Toolbar.
- Select Check for Updates.
- If a newer version of the SmartVault Desktop software is available, a dialog box displays and allows you to choose whether you want to install the newer version of the SmartVault Desktop software now or later. Click Install Now, and then restart QuickBooks and the SmartVault Desktop software.
This automatically connects you to the SmartVault server and checks to see if you have the most current version of the SmartVault Desktop software.
Knowledge Base ID
KB286


Comments on this entry are closed.