Error: The QuickBooks SDK has failed to register the SmartVault user interface extension

Symptoms

  • Error: The QuickBooks SDK has failed to register the SmartVault user interface extension.
  • SmartVault Toolbar is not active (grayed out) when a QuickBooks entry is selected.
  • SmartVault Toolbar displays only on the Home, Reports, and Snapshot pages in QuickBooks.
  • SmartVault is not listed on the Company menu in QuickBooks.
  • SmartVault Toolbar does not display in QuickBooks after installing the SmartVault Desktop software and adding a QuickBooks company file to SmartVault.
  • SmartVault Toolbar doesn’t do anything when you click Sign in on the SmartVault Toolbar.

Cause

This issue occurs when there is a communication problem, or more technically, a registration problem, between SmartVault and QuickBooks. In order for SmartVault and QuickBooks to communicate, QuickBooks requires that SmartVault write a specific file to the \ProgramFiles\Intuit\QBVersion\Components\RegisteredUI folder on your computer. However, this error indicates that SmartVault cannot write this file to the folder because SmartVault does not have write permissions for this folder.

This problem most often occurs when you perform the following actions:

  • You install SmartVault on a Windows 7 computer where QuickBooks 2011 is installed and User Account Controls (UAC) are set to med-high or high.
  • You install SmartVault on a Windows Vista computer where QuickBooks 2011 is installed and UAC is enabled.
  • You have upgraded an existing installation of QuickBooks with SmartVault to the latest QuickBooks version in a different directory on a Windows XP, Windows Vista, or Windows 7 computer.
  • You have updated the QuickBooks SDK as a result of a QuickBooks update on a Windows XP, Windows Vista, or Windows 7 computer.

Resolution

To resolve this issue, ensure that SmartVault is correctly registered with QuickBooks.

If you use Microsoft Windows 7, complete the following steps:

  1. Run QuickBooks as local administrator by completing the following steps:
    1. Close QuickBooks.
    2. Exit SmartVault by right clicking on the SmartVault icon in the system tray on your computer and then clicking Exit.
    3. Right click on the QuickBooks shortcut on your desktop and select the Run as Administrator… option.
    4. Enter the administrator credentials if prompted, or click OK on the prompt that permits QuickBooks to bypass the UAC.
    5. Sign in to SmartVault when prompted.
    6. Verify that SmartVault is listed in the Company menu in QuickBooks.
  2. If the SmartVault toolbar does not display as active on the right of the QuickBooks Home page, temporarily disable UAC to minimum levels by completing the following steps:
    1. Click the Start button on your computer.
    2. In the Search programs and files field, type User Accounts.
    3. In the list under Control Panel, click Change User Account Control Settings.
    4. Note what the current setting is for the slider bar, and then slide the slider bar to the lowest value (towards Never notify) until the description Never notify me when displays.
    5. Click OK and then click Yes to make the change effective.
    6. Restart the computer and then open QuickBooks.
    7. Sign in to SmartVault when prompted.
    8. Verify that the SmartVault Toolbar displays on the right of the QuickBooks Home page and is active.
    9. Re-enable user account controls by repeating steps a-c, slide the slider bar back to the original setting that you noted in step d, and then click OK and Yes to make the change effective.

If you use Microsoft Windows Vista, complete the following steps:

  1. Run QuickBooks as local administrator by completing the following steps:
    1. Close QuickBooks.
    2. Exit SmartVault by right clicking on the SmartVault icon in the system tray on your computer and then clicking Exit.
    3. Right click on the QuickBooks shortcut on your desktop and select the Run as Administrator… option.
    4. Enter the administrator credentials if prompted, or click OK on the prompt that permits QuickBooks to bypass the UAC.
    5. Sign in to SmartVault when prompted.
    6. Verify that SmartVault is listed in the Company menu in QuickBooks.
  2. If the SmartVault toolbar does not display as active on the right of the QuickBooks Home page, run the SmartVault Vista QuickBooks fix by completing the following steps:
    1. Close QuickBooks.
    2. Exit SmartVault by right clicking on the SmartVault icon in the system tray on your computer and then clicking Exit.
    3. In Windows Explorer, browse to the \Program Files (or Program Files (x86) on a 64-bit computer)\SmartVault folder.
    4. Double-click the file Svault.Client.VistaFixQB.exe to run the file.
    5. If UAC is enabled, give permission to SmartVault to run the file.
    6. Within a few seconds, the message Your computer is now ready for use displays.
    7. Open QuickBooks.
    8. Sign in to SmartVault when prompted.
    9. Verify that the SmartVault Toolbar displays on the right of the QuickBooks Home page and is active.

If you use Microsoft Windows XP, complete the following steps:

  1. Run QuickBooks as a local administrator by completing the following steps:
    1. Close QuickBooks.
    2. Exit SmartVault by right-clicking on the SmartVault icon in the system tray on your computer and then clicking Exit.
    3. Right-click on the QuickBooks shortcut on your desktop and select the Run as Administrator… option.
    4. Enter the administrator credentials if prompted.
    5. Sign in to SmartVault when prompted.
    6. Verify that SmartVault is listed in the Company menu in QuickBooks.
  2. If the SmartVault toolbar does not display as active on the right of the QuickBooks Home page, uninstall and then reinstall SmartVault by completing the following steps:
    1. Close QuickBooks.
    2. Exit SmartVault by right-clicking on the SmartVault icon in the system tray on your computer and then clicking Exit.
    3. Click Start > Run and then type Control Panel.
    4. Open Add/Remove Programs.
    5. Select SmartVault, and then click Remove.
    6. Follow the wizard to uninstall SmartVault.
    7. Sign into the SmartVault web portal.
    8. Under Resources, click Download SmartVault Desktop.
    9. Follow the prompts to install SmartVault.
    10. Open QuickBooks and sign into SmartVault when prompted.
    11. Verify that the SmartVault Toolbar displays on the right of the QuickBooks Home page and is active.

Knowledge Base ID

KB300

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