Symptoms
- You are using the One Window view in QuickBooks 2012 and the SmartVault Toolbar displays as active, but when you open a QuickBooks transaction, the SmartVault Toolbar displays as inactive, or grayed out.
- You are using the Multiple Windows view in QuickBooks 2012 but the window is not maximized, and the SmartVault Toolbar displays as inactive, or grayed out for all QuickBooks transactions except for the Home, Snapshots, and Reports page.
Error: The QuickBooks SDK has failed to register the SmartVault user interface extensiondisplays when you open QuickBooks 2012.
Cause
This issue occurs if you are using QuickBooks 2012.
In QuickBooks 2012, Intuit made changes to their software development kit (SDK). The Intuit SDK is a set of tools that third-party software companies, like SmartVault, use to develop applications that integrate with QuickBooks.
Changes Intuit made to their SDK in QuickBooks 2012 prevent the SmartVault Toolbar from displaying correctly when you are using QuickBooks with the One Window view or when you are using QuickBooks with the Multiple Windows view but the window is not maximized.
Resolution
This is a known issue with SmartVault and QuickBooks 2012. SmartVault is aware of this problem and will work with Intuit to develop a fix for this issue in a future SmartVault release.
However, until SmartVault and Intuit resolve this issue, use QuickBooks 2012 in Multiple Windows view with the working window maximized.
To use QuickBooks in Multiple Windows mode:
- In QuickBooks, on the View menu, click Multiple Windows.
If the SmartVault Toolbar still displays as active, or grayed out, after you have set your view to Multiple Windows, use the Refresh link on the SmartVault menu in QuickBooks to activate the SmartVault Toolbar by completing the following steps:
- In QuickBooks, on the Company menu, click SmartVault, and then click Refresh.
If the error message Error: The QuickBooks SDK has failed to register the SmartVault user interface extension displays when you click Refresh, simply click Close to close the error message.
SmartVault continues to support and work with all previous versions of QuickBooks from QuickBooks 2006 through QuickBooks 2012. A complete list of the types of QuickBooks entries you can attach documents to using the SmartVault Toolbar, as well as examples of documents that could be attached to each entry, is available at http://help.smartvault.com/help/docs/DocumentTypes.pdf.
Knowledge Base ID
KB314


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